Ubuntu – Compile and install rtl8192cu driver

Ubuntu – Compile and install rtl8192cu driver

driversrealtekwireless

Can someone help me with this problem ? I am new to Linux, so I do not know commands and I never did something like installing or compiling with command-line.

I bought WiFi adapter from Edimax, model EW-7811UN for my PC (not laptop, so I do not have wifi card, only ethernet). When I go through guide on CD, I came across a version of kernel. It said I need version 2.6, but I have 3.5.0-22-generic.

I got errors like I do not have file or folder etc. Can someone tell me where I can download compiled driver and where I need to put it? Or some other advice. I don’t want downgrade kernel when it is not necessary.

Best Answer

  • If you run into this problem, what worked for me was installing the following driver: https://github.com/pvaret/rtl8192cu-fixes

    From the README.md file:

    Installation

    Ensure you have the necessary prerequisites:

    sudo apt-get install linux-headers-generic build-essential dkms
    

    Clone this repository:

    git clone https://github.com/pvaret/rtl8192cu-fixes.git
    

    Set it up as a DKMS module:

    sudo dkms add ./rtl8192cu-fixes
    

    Build and install it (this version number may change, it is .11 as of November 07 2019)

    sudo dkms install 8192cu/1.11
    

    Refresh the module list:

    sudo depmod -a
    

    Ensure the native (and broken) kernel driver is blacklisted:

    sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
    

    And reboot. You’re done.

  • Add a Comment

    Your email address will not be published. Required fields are marked *